Place for chatting and discussing anything unrelated to swifts.
  • User avatar
User avatar
By blueturbofly
Donations Avatar
#14391
so, 2 weeks of work with the '‘new’' parts guy- the other parts guy took 2 weeks off….the new parts guy has changed around the office dynamic, instead of leaving the customer at the front counter while you walk away to a separate office to look up parts, he moved the computer and monitor up to the front counter, so you dont have to turn your back to a customer when looking up parts…that is NOT going to go over well with the old parts guy, who liked hanging out in the secluded office , watching jennifer love huge tits on the computer…
will wait and see how this plays out… :laugh:
fireflyse, Walt liked this
User avatar
By blueturbofly
Donations Avatar
#14396
new parts guy has already moved some shelving around….set up account portals, so there is no real need to call any supplier for parts, just look on their site, and if they have the parts, order said parts. making things easy. but pulling out what is left of his hair, at the other parts guys paperwork system…terrible paperwork.
there is even now a computer set up at the front desk, so you are always forward and facing the customer when they come in. ;-) no more running away to a back room to look up parts…
and the new parts guy is alot more '‘proactive’‘ when it comes to parts-he keeps a good paper trail. may just make the business run more ’‘lean’'- no more keeping parts in stock, that were /are not needed…

replaced a complete engine on a generator….the owner put the connecting rod thru the top of the block :-o and warranty gave him a replacement engine for free!!! it has a 5 year warranty on the ENTIRE UNIT…including the engine! not a bad warranty….

another larger gen set…would not start….actually 2 from the same fellow, a large champion 12,000w and a smaller firman 3000w suitcase. told me that his '‘mechanic ’' cleaned the carb, but it still would not run. I told him that i will decide if the carb is clean or not….but the smaller genset was under warranty, and we are not the warranty depo for that brand- so he took it somewhere else-in the meantime….
the big champion generator? carb full of water and water in the fuel tank. flushed it out as best as possible. runs great.
customer picks up the big generator, drops off the little one again- if its just carb work, it may not be covered under warranty if its bad fuel or clogged….
went to drain the carb of fuel, and it was rather clear and didnt smell or look gas like…um…it was straight water!!! :-o lots of water!!! 4 large glass jars of water, hardly any gas in the 5th jar….
and lots of water in the engine oil- noted complaint of '‘foamy engine oil’'- so i changed the oil as well.
blew out the tank, then flushed with fresh fuel…blew the water out of the carb….
it took some cranking, but it fired up!! :-D
so, both his generators, water in the fuel tanks…..hmmm
and its been getting warm….the shop i am in, has very poor insulation….its almost as hot inside, as outside…it was 28*c inside yesterday…and i do have some air movement, but not too much, or else it blows around dirt / dust in the carbs or whatnot that i am cleaning….

warranty lawnmower-took an entire engine apart (split the case) complaint of '‘engine went pop and quit’' after checking all the generic outside parts ( oil, air, fuel, spark) i cracked the case- the engine would pop out the carb, but dump fuel out the muffler…out of time?
NOPE. timing marks line up good from crank to cam, the PLASTIC gears and cam lobes looked ok, but there is always a possibility of the plastic cam lobes '‘spinning’' on there steel shaft (the lobes are just pressed on !!)
re-assemble engine, do more checks- spark seems crappy- very inconsistent….weird, i had already checked for spark, before opening engine, and it was good…or so i thought.
installed a good used test coil. and the mower fired right up :-o that was annoying, to say the least. :mad: after i had the whole darn thing apart, it was a faulty coil …always a curve ball, not every engine, that presents the same issues, has the same problem….
but, i have had 4 of the same brand mowers come in over the last 2 weeks, under warranty-same issues, will not restart….the engines have auto chokes, and they dont work the greatest once warmed up, but they still start….i cant fix it, if it isnt broken…. :laugh:
  • 1
  • 22
  • 23
  • 24
  • 25
  • 26
What did you do to your Swift today

replaced a passengers side door handle that had br[…]

https://www.youtube.com/watch?v=2aKX9EP1ecU&t=[…]

new job

new parts guy has already moved some shelving arou[…]

92 Black GT

I sorted a few loose ends today. My new Race Spor[…]