Discussion on anything swift related. Got a new whip? Spotted a swift somewhere? Just want to shoot the breeze about your cars?
  • User avatar
  • User avatar
  • User avatar
User avatar
By nwgeo
Posts Avatar
#14533
Out driving my 94 GT. Pushing it pretty good through the gears, not more than 5,500 RPM, in any gear. I am at about 60 MPH in 3rd about ready to shift into 4th and I hear a slight boom and huge blue smoke out the back. :mad: I put the clutch in, and turn out the engine and coast still some blue smoke out the back, think oh man :-( blew a head gasket or a valve, pull over pull open the hood, nothing looks off… checked the timing belt etc. start it back up, starts fine, runs okay, blue smoke out the tail pipe. but not as much and drive another mile home and the blue smoke dissipates. drive it the next few days, even push it some…no problems. Don’t know what it could have been? Like a plug of oil went through the engine. Crazy :-/
fireflyse, Walt liked this
User avatar
By blueturbofly
Donations Avatar
#14546
changed spark plugs in the daily driver big clutch- noticed it getting harder to '‘lite off’' when starting it. been around these cars long enough to know when the spark plugs need to be done.
so, install 3 bpr5es ngk plugs- fires up alot quicker. now to see how much the fuel mileage changes…. :laugh:
Walt liked this
User avatar
By blueturbofly
Donations Avatar
#14551
changed out a bad ballast / bulb yesterday morning before work- not sure which one was the culprit, tried another ballast, still didnt light up, installed another bulb, no change, changed ballast again, and it lights up!! will check those other ballasts i have on hand…
User avatar
By blueturbofly
Donations Avatar
#14650
oldest son changed out an alternator on one of the daily drivers ,that has very noisy bearings :-o

youngest son may take it apart and install new bearings- it still charges good, and is a 55 amp unit….
Walt liked this
User avatar
By blueturbofly
Donations Avatar
#14663
changed out a leaking master cyl yesterday, bled the brakes, had a really hard time rotating one rear drum, opened that up, didnt see any problems, re-adjusted the slack adjuster so the drum spins freely but stops good, doesnt bind, bearings are good.
most likely that was the reason why the car was handling odd, and is using a little more fuel- sticking drum brake!!!
odd tire wear on the rh front-on the inside edge, but not feathering like bad tie-rods…..the struts and lca’s are fairly new…? hmm

polished the headlamp lens- so nice and clear again!

tied up the vent hose for the fuel tank- noticed it was hanging lower than the fuel filler hose- HOPEFULLY that was the issue with filling the tank-it was always slow going and would burp and purge gas from the filler pipe , when filling :mad:

alternator is nice and quiet ;-)
Walt liked this
User avatar
By blueturbofly
Donations Avatar
#14666
yesterday- changed a leaking axle seal- must have just started leaking. changed trans fluid-lots of glitter in oil- :-o more than expected, the oil removed wasnt that old-
turned up the idle , with the proper idle up screw thats under the rubber cap, on the side of the throttle body.

might try tinting the rear window today.
Walt liked this
User avatar
By blueturbofly
Donations Avatar
#14667
brought the ’87 in for a little more work. will tint the rear glass as well as repair the rh front caliper that is sticky..

window is tinted on the ’93- not my best work, i usually take the windows completely out of the car for the tinting procedure-but not that hatch glass- too many other things to disconnect :laugh:

also brought the firefly truck in, just to stay warm-might as well, i got the room…
Image
Walt liked this
  • 1
  • 35
  • 36
  • 37
  • 38
  • 39
'87 Suzuki Swift commercial

looking good!! i like the flat floor- my do the sa[…]

i MIGHT have a rear washer / wiper switch in a '[…]

new job

That is great news :party: Good luck sorting o[…]

Turbo Query RHB32

Info is scarce on the RHB32 water cooled turbo, al[…]